high7.7
CVE-2026-25958
Cube Core is vulnerable to privilege escalation via a specially crafted request
Impact
### **Impact** It is possible to make a specially crafted request with a valid API token that leads to privilege escalation. ### Affected Versions: `≥= 0.27.19` ### Mitigation: Upgrade to a patched version: - 1.5.13 and later (regular release) - 1.4.2 (active [LTS release](https://cube.dev/docs/product/administration/distribution#long-term-support)) - 1.0.14 (end-of-life LTS release) ### **References** The issue was reported by our Core engineer, Dmitrii Patsura (@ovr), in our internal Slack and was promptly patched in a recent update.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | @cubejs-backend/server-core | >= 0.27.19, < 1.0.14 | 1.0.14 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Cube | Cube.Js | from 0.27.19 before 1.0.14 from 1.1.0 before 1.4.2 from 1.5.0 before 1.5.13 |