critical9.8
CVE-2026-27820
Buffer Overflow in Zlib::GzipReader ungetc via large input leads to memory corruption
Impact
zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader. The zstream_buffer_ungets function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity. This issue has been fixed in versions 3.0.1, 3.1.2 and 3.2.3.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| rubygems | zlib | >= 3.2.0, < 3.2.3 | 3.2.3 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Ruby-Lang | Zlib | before 3.0.1 from 3.1.0 before 3.1.2 from 3.2.0 before 3.2.3 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-g857-hhfv-j68w
- https://github.com/ruby/zlib/security/advisories/GHSA-g857-hhfv-j68w
- https://nvd.nist.gov/vuln/detail/CVE-2026-27820
- https://hackerone.com/reports/3467067
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/zlib/CVE-2026-27820.yml
- https://www.ruby-lang.org/en/news/2026/03/05/buffer-overflow-zlib-cve-2026-27820