NetSight
medium6.1

CVE-2026-28223

Wagtail Vulnerable to Cross-site Scripting in simple_translation admin interface

Impact

### Impact A stored Cross-site Scripting (XSS) vulnerability exists on confirmation messages within the `wagtail.contrib.simple_translation` module. A user with access to the Wagtail admin area may create a page with a specially-crafted title which, when another user performs the "Translate" action, causes arbitrary JavaScript code to run. This could lead to performing actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. ### Patches Patched versions have been released as Wagtail 6.3.8, 7.0.6, 7.2.3 and 7.3.1. ### Workarounds None ### Acknowledgements Many thanks to Guan Chenxian (@GCXWLP) for reporting this issue. ### For more information If there are any questions or comments about this advisory: - Visit Wagtail's [support channels](https://docs.wagtail.io/en/stable/support.html) - Email Wagtail at [security@wagtail.org](mailto:security@wagtail.org) (view the [security policy](https://github.com/wagtail/wagtail/security/policy) for more information).

Affected packages

EcosystemPackageAffectedFixed in
pipwagtail< 6.3.86.3.8

Affected products

VendorProductAffected versions
TorchboxWagtail
before 6.3.8
from 6.4 before 7.0.6
from 7.1 before 7.2.3
Version 7.3

Weakness classification

References