CVE-2026-28291
simple-git Affected by Command Execution via Option-Parsing Bypass
Impact
simple-git enables running native Git commands from JavaScript. Versions up to and including 3.31.1 allow execution of arbitrary commands through Git option manipulation, bypassing safety checks meant to block dangerous options like -u and --upload-pack. The flaw stems from an incomplete fix for CVE-2022-25860, as Git's flexible option parsing allows numerous character combinations (e.g., -vu, -4u, -nu) to circumvent the regular-expression-based blocklist in the unsafe operations plugin. Due to the virtually infinite number of valid option variants that Git accepts, a complete blocklist-based mitigation may be infeasible without fully emulating Git's option parsing behavior. This issue has been fixed in version 3.32.0.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | simple-git | < 3.32.0 | 3.32.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Simple-Git Project | Simple-Git | before 3.32.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/steveukx/git-js/blob/789c13ebabcf18ebe0b3a0c88ebb4037dede42e3/simple-git/src/lib/plugins/block-unsafe-operations-plugin.ts#L26
- https://github.com/steveukx/git-js/commit/1effd8e5012a5da05a9776512fac3e39b11f2d2d
- https://github.com/steveukx/git-js/releases/tag/simple-git%403.32.0
- https://github.com/steveukx/git-js/security/advisories/GHSA-jcxm-m3jx-f287
- https://www.cve.org/CVERecord?id=CVE-2022-25860
- https://access.redhat.com/security/cve/CVE-2026-28291
- https://bugzilla.redhat.com/show_bug.cgi?id=2457930
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-28291.json
- https://github.com/advisories/GHSA-jcxm-m3jx-f287
- https://nvd.nist.gov/vuln/detail/CVE-2026-28291