high8.7
CVE-2026-28426
Statamic vulnerable to privilege escalation via stored cross-site scripting
Impact
### Impact Stored XSS vulnerability in svg and icon related components allow authenticated users with appropriate permissions to inject malicious JavaScript that executes when viewed by higher-privileged users. ### Patches This has been fixed in 5.73.11 and 6.4.0.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | statamic/cms | < 5.73.11 | 5.73.11 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Statamic | Statamic | before 5.73.11 from 6.0.0 before 6.4.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/statamic/cms/releases/tag/v5.73.11
- https://github.com/statamic/cms/releases/tag/v6.4.0
- https://github.com/statamic/cms/security/advisories/GHSA-5vrj-wf7v-5wr7
- https://github.com/advisories/GHSA-5vrj-wf7v-5wr7
- https://nvd.nist.gov/vuln/detail/CVE-2026-28426