NetSight
high7.5

CVE-2026-29129

Configured cipher preference order not preserved vulnerability in Apache Tomcat.

Impact

Configured cipher preference order not preserved vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.16 through 11.0.18, from 10.1.51 through 10.1.52, from 9.0.114 through 9.0.115. Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.tomcat:tomcat>= 9.0.114, < 9.0.1169.0.116
mavenorg.apache.tomcat.embed:tomcat-embed-core>= 9.0.114, < 9.0.1169.0.116
mavenorg.apache.tomcat:tomcat-coyote>= 9.0.114, < 9.0.1169.0.116

Affected products

VendorProductAffected versions
ApacheTomcat
from 9.0.114 before 9.0.116
from 10.1.51 before 10.1.53
from 11.0.16 before 11.0.20

Weakness classification

References