NetSight
critical9.1

CVE-2026-31908

Header injection vulnerability in Apache APISIX.

Impact

Header injection vulnerability in Apache APISIX. The attacker can take advantage of certain configuration in forward-auth plugin to inject malicious headers. This issue affects Apache APISIX: from 2.12.0 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.

Affected products

VendorProductAffected versions
ApacheApisix
from 2.12.0 before 3.16.0

Weakness classification

References