high7.5
CVE-2026-31923
Cleartext Transmission of Sensitive Information vulnerability in Apache APISIX.
Impact
Cleartext Transmission of Sensitive Information vulnerability in Apache APISIX. This can occur due to `ssl_verify` in openid-connect plugin configuration being set to false by default. This issue affects Apache APISIX: from 0.7 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Apisix | from 0.7 before 3.16.0 |