NetSight
medium6.1

CVE-2026-32773

There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code whi…

Impact

There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later. This CVE is marked as "low" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page. Users are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.

Affected packages

EcosystemPackageAffectedFixed in
pippyspark>= 3.0.0, < 3.5.83.5.8
mavenorg.apache.spark:spark-core_2.12>= 3.0.0, < 3.5.83.5.8
mavenorg.apache.spark:spark-core_2.13>= 3.0.0, < 3.5.83.5.8

Affected products

VendorProductAffected versions
ApacheSpark
from 3.0.0 before 3.5.8

Weakness classification

References