NetSight
medium5.3

CVE-2026-32990

Improper Input Validation vulnerability in Apache Tomcat due to an incomplete fix of CVE-2025-66614.

Impact

Improper Input Validation vulnerability in Apache Tomcat due to an incomplete fix of CVE-2025-66614. This issue affects Apache Tomcat: from 11.0.15 through 11.0.19, from 10.1.50 through 10.1.52, from 9.0.113 through 9.0.115. Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.tomcat:tomcat>= 9.0.113, < 9.0.1169.0.116
mavenorg.apache.tomcat.embed:tomcat-embed-core>= 9.0.113, < 9.0.1169.0.116
mavenorg.apache.tomcat:tomcat-coyote>= 9.0.113, < 9.0.1169.0.116

Affected products

VendorProductAffected versions
ApacheTomcat
from 9.0.113 before 9.0.116
from 10.1.50 before 10.1.53
from 11.0.15 before 11.0.20

Weakness classification

References