CVE-2026-33227
Improper validation and restriction of a classpath path name vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ All, Apache Activ…
Impact
Improper validation and restriction of a classpath path name vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ Web, Apache ActiveMQ. In two instances (when creating a Stomp consumer and also browsing messages in the Web console) an authenticated user provided "key" value could be constructed to traverse the classpath due to path concatenation. As a result, the application is exposed to a classpath path resource loading vulnerability that could potentially be chained together with another attack to lead to exploit. This issue affects Apache ActiveMQ Client: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ Broker: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ All: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ Web: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ: before 5.19.3, from 6.0.0 before 6.2.2. Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue. Note: 5.19.3 and 6.2.2 also fix this issue, but that is limited to non-Windows environments due to a path separator resolution bug fixed in 5.19.4 and 6.2.3.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.activemq:activemq-client | < 5.19.3 | 5.19.3 |
| maven | org.apache.activemq:activemq-broker | < 5.19.3 | 5.19.3 |
| maven | org.apache.activemq:activemq-all | < 5.19.3 | 5.19.3 |
| maven | org.apache.activemq:activemq-web | < 5.19.3 | 5.19.3 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Activemq | before 5.19.3 from 6.0.0 before 6.2.2 |
| Apache | Activemq Broker | before 5.19.3 from 6.0.0 before 6.2.2 |
| Apache | Activemq Web | before 5.19.3 from 6.0.0 before 6.2.2 |