NetSight
high7.5

CVE-2026-3336

Improper certificate validation in PKCS7_verify() in AWS-LC allows an unauthenticated user to bypass certificate chain verification when processing PKCS7 objec…

Impact

Improper certificate validation in PKCS7_verify() in AWS-LC allows an unauthenticated user to bypass certificate chain verification when processing PKCS7 objects with multiple signers, except the final signer. Customers of AWS services do not need to take action. Applications using AWS-LC should upgrade to AWS-LC version 1.69.0.

Affected products

VendorProductAffected versions
AmazonAws-Lc-Sys
from 0.24.0 before 0.38.0
AmazonAws Libcrypto
from 1.41.0 before 1.69.0

Weakness classification

References