NetSight
high7.2

CVE-2026-33539

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js.

Impact

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.59 and 9.6.0-alpha.53, an attacker with master key access can execute arbitrary SQL statements on the PostgreSQL database by injecting SQL metacharacters into field name parameters of the aggregate $group pipeline stage or the distinct operation. This allows privilege escalation from Parse Server application-level administrator to PostgreSQL database-level access. Only Parse Server deployments using PostgreSQL are affected. MongoDB deployments are not affected. This issue has been patched in versions 8.6.59 and 9.6.0-alpha.53.

Affected packages

EcosystemPackageAffectedFixed in
npmparse-server>= 9.0.0, < 9.6.0-alpha.539.6.0-alpha.53

Affected products

VendorProductAffected versions
ParseplatformParse-Server
before 8.6.59
from 9.0.0 before 9.6.0
Version 9.6.0

Weakness classification

References