high8.8
CVE-2026-33858
Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code.
Impact
Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code. Since Dag Authors are already highly trusted, severity of this issue is Low. Users are recommended to upgrade to Apache Airflow 3.2.0, which resolves this issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | apache-airflow | >= 3.1.8, < 3.2.0 | 3.2.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Airflow | from 3.1.8 before 3.2.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/apache/airflow/pull/64148
- https://lists.apache.org/thread/1npt3o2x81s0gw9tmfcv4n7p1z9hdmy0
- http://www.openwall.com/lists/oss-security/2026/04/13/7
- https://github.com/advisories/GHSA-mc4f-r875-v87w
- https://nvd.nist.gov/vuln/detail/CVE-2026-33858
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2026-20.yaml