NetSight
medium6.8

CVE-2026-33997

Moby has an Off-by-one error in its plugin privilege validation

Impact

Moby is an open source container framework. Prior to version 29.3.1, a security vulnerability has been detected that allows plugins privilege validation to be bypassed during docker plugin install. Due to an error in the daemon's privilege comparison logic, the daemon may incorrectly accept a privilege set that differs from the one approved by the user. Plugins that request exactly one privilege are also affected, because no comparison is performed at all. This issue has been patched in version 29.3.1.

Affected packages

EcosystemPackageAffectedFixed in
gogithub.com/docker/docker< 29.3.1none recorded
gogithub.com/moby/moby< 29.3.1none recorded
gogithub.com/moby/moby/v2< 2.0.0-beta.82.0.0-beta.8

Affected products

VendorProductAffected versions
DockerEngine
before 29.3.1

Weakness classification

References