high8.8
CVE-2026-34040
Moby has AuthZ plugin bypass when provided oversized request bodies
Impact
Moby is an open source container framework. Prior to version 29.3.1, a security vulnerability has been detected that allows attackers to bypass authorization plugins (AuthZ). This issue has been patched in version 29.3.1.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| go | github.com/moby/moby | < 29.3.1 | 29.3.1 |
| go | github.com/moby/moby/v2 | < 2.0.0-beta.8 | 2.0.0-beta.8 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Docker | Engine | before 29.3.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-x744-4wpc-v9h2
- https://github.com/moby/moby/security/advisories/GHSA-v23v-6jw2-98fq
- https://github.com/moby/moby/security/advisories/GHSA-x744-4wpc-v9h2
- https://github.com/moby/moby/commit/e89edb19ad7de0407a5d31e3111cb01aa10b5a38
- https://docs.docker.com/engine/extend/plugins_authorization
- https://nvd.nist.gov/vuln/detail/CVE-2026-34040
- https://github.com/moby/moby/releases/tag/docker-v29.3.1