critical9.8
CVE-2026-34060
Ruby LSP is an implementation of the language server protocol for Ruby.
Impact
Ruby LSP is an implementation of the language server protocol for Ruby. Prior to Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9, the rubyLsp.branch VS Code workspace setting was interpolated without sanitization into a generated Gemfile, allowing arbitrary Ruby code execution when a user opens a project containing a malicious .vscode/settings.json. This issue has been patched in Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| rubygems | ruby-lsp | < 0.26.9 | 0.26.9 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Shopify | Ruby Lsp | before 0.10.2 before 0.26.9 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-c4r5-fxqw-vh93
- https://github.com/Shopify/ruby-lsp/security/advisories/GHSA-c4r5-fxqw-vh93
- https://github.com/Shopify/ruby-lsp/releases/tag/v0.26.9
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby-lsp/CVE-2026-34060.yml
- https://nvd.nist.gov/vuln/detail/CVE-2026-34060