high7.5
CVE-2026-34077
React Router vulnerable to Denial of Service via reflected user input in single-fetch
Impact
React Router is a router for React. In versions 7.7.0 through 7.13.1, when using React Router's unstable React Server Components (RSC) APIs, there is a potential client-side Cross-Site Scripting (XSS) vulnerability in the RSC redirect handling if redirects come from untrusted sources. This does not impact applications that are not using the unstable RSC APIs in React Router. This is patched in version 7.13.2.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | react-router | >= 7.0.0, < 7.14.0 | 7.14.0 |
| npm | turbo-stream | < 3.0.0 | 3.0.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Shopify | React-Router | from 7.0.0 before 7.14.0 |
| Turbo-Stream | Turbo Stream | before 3.0.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-rxv8-25v2-qmq8
- https://github.com/remix-run/react-router/security/advisories/GHSA-rxv8-25v2-qmq8
- https://nvd.nist.gov/vuln/detail/CVE-2026-34077
- https://github.com/remix-run/react-router/commit/59811921d3c7d599077b8cadccdcd65a233165e0
- https://github.com/jacob-ebey/turbo-stream/blob/v2.4.1/src/flatten.ts#L175-L177
- https://github.com/jacob-ebey/turbo-stream/blob/v2.4.1/src/unflatten.ts#L185-L189