NetSight
critical9.8

CVE-2026-34400

alerta-server has potential SQL Injection vulnerability in Query String Syntax (q=) API

Impact

Alerta is a monitoring tool. Prior to version 9.1.0, the Query string search API (q=) was vulnerable to SQL injection via the Postgres query parser, which built WHERE clauses by interpolating user-supplied search terms directly into SQL strings via f-strings. This issue has been patched in version 9.1.0.

Affected packages

EcosystemPackageAffectedFixed in
pipalerta-server< 9.1.09.1.0

Affected products

VendorProductAffected versions
Alerta ProjectAlerta
before 9.1.0

Weakness classification

References