high7.1
CVE-2026-34476
Server-Side Request Forgery via SW-URL Header vulnerability in Apache SkyWalking MCP.
Impact
Server-Side Request Forgery via SW-URL Header vulnerability in Apache SkyWalking MCP. This issue affects Apache SkyWalking MCP: 0.1.0. Users are recommended to upgrade to version 0.2.0, which fixes this issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| go | github.com/apache/skywalking-mcp | < 0.2.0 | 0.2.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Skywalking Mcp | from 0.1.0 before 0.2.0 |