high7.5
CVE-2026-34483
Improper Encoding or Escaping of Output vulnerability in the JsonAccessLogValve component of Apache Tomcat.
Impact
Improper Encoding or Escaping of Output vulnerability in the JsonAccessLogValve component of Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.20, from 10.1.0-M1 through 10.1.53, from 9.0.40 through 9.0.116. Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117 , which fix the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.tomcat:tomcat-catalina | >= 9.0.40, < 9.0.116 | 9.0.116 |
| maven | org.apache.tomcat:tomcat | >= 9.0.40, < 9.0.116 | 9.0.116 |
| maven | org.apache.tomcat.embed:tomcat-embed-core | >= 9.0.40, < 9.0.116 | 9.0.116 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Tomcat | from 9.0.40 before 9.0.117 from 10.1.0 before 10.1.54 from 11.0.0 before 11.0.21 |