NetSight
critical9.9

CVE-2026-34571

CI4MS: Stored Cross‑Site Scripting (Stored XSS) in Backend User Management Allows Session Hijacking and Full Administrative Account Compromise

Impact

CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. Prior to version 0.31.0.0, a Stored Cross-Site Scripting (Stored XSS) vulnerability exists in the backend user management functionality. The application fails to properly sanitize user-controlled input before rendering it in the administrative interface, allowing attackers to inject persistent JavaScript code. This results in automatic execution whenever backend users access the affected page, enabling session hijacking, privilege escalation, and full administrative account compromise. This issue has been patched in version 0.31.0.0.

Affected packages

EcosystemPackageAffectedFixed in
composerci4-cms-erp/ci4ms<= 0.28.6.00.31.0.0

Affected products

VendorProductAffected versions
Ci4-Cms-ErpCi4ms
before 0.31.0.0

Weakness classification

References