NetSight
high8.7

CVE-2026-3520

Multer Vulnerable to Denial of Service via Uncontrolled Recursion

Impact

### Impact A vulnerability in Multer versions < 2.1.1 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing stack overflow. ### Patches Users should upgrade to `2.1.1` ### Workarounds None ### Resources - https://github.com/expressjs/multer/security/advisories/GHSA-5528-5vmv-3xc2 - https://www.cve.org/CVERecord?id=CVE-2026-3520 - https://github.com/expressjs/multer/commit/7e66481f8b2e6c54b982b34c152479e096ce2752 - https://cna.openjsf.org/security-advisories.html

Affected packages

EcosystemPackageAffectedFixed in
npmmulter< 2.1.12.1.1

Affected products

VendorProductAffected versions
ExpressjsMulter
before 2.1.1

Weakness classification

References