NetSight
critical9.4

CVE-2026-39397

@delmaredigital/payload-puc is missing authorization on /api/puck/* CRUD endpoints allows unauthenticated access to Puck-registered collections

Impact

@delmaredigital/payload-puck is a PayloadCMS plugin for integrating Puck visual page builder. Prior to 0.6.23, all /api/puck/* CRUD endpoint handlers registered by createPuckPlugin() called Payload's local API with the default overrideAccess: true, bypassing all collection-level access control. The access option passed to createPuckPlugin() and any access rules defined on Puck-registered collections were silently ignored on these endpoints. This vulnerability is fixed in 0.6.23.

Affected packages

EcosystemPackageAffectedFixed in
npm@delmaredigital/payload-puck< 0.6.230.6.23

Affected products

VendorProductAffected versions
DelmaredigitalPayload-Puck
before 0.6.23

Weakness classification

References