NetSight
high8.8

CVE-2026-39998

Improper Input Validation vulnerability in Apache APISIX.

Impact

Improper Input Validation vulnerability in Apache APISIX. The attacker can take advantage of certain configuration in forward-auth plugin to spoof identity headers. This issue affects Apache APISIX: from 2.12.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Affected products

VendorProductAffected versions
ApacheApisix
from 2.12.0 before 3.17.0

Weakness classification

References