NetSight
medium5.3

CVE-2026-40347

python-multipart affected by Denial of Service via large multipart preamble or epilogue data

Impact

Python-Multipart is a streaming multipart parser for Python. Versions prior to 0.0.26 have a denial of service vulnerability when parsing crafted `multipart/form-data` requests with large preamble or epilogue sections. Upgrade to version 0.0.26 or later, which skips ahead to the next boundary candidate when processing leading CR/LF data and immediately discards epilogue data after the closing boundary.

Affected packages

EcosystemPackageAffectedFixed in
pippython-multipart< 0.0.260.0.26

Affected products

VendorProductAffected versions
FastapiexpertPython-Multipart
before 0.0.26

Weakness classification

References