NetSight
high8.8

CVE-2026-40459

PAC4J is vulnerable to LDAP Injection in multiple methods.

Impact

PAC4J is vulnerable to LDAP Injection in multiple methods. A low-privileged remote attacker can inject crafted LDAP syntax into ID-based search parameters, potentially resulting in unauthorized LDAP queries and arbitrary directory operations. This issue was fixed in PAC4J versions 4.5.10, 5.7.10 and 6.4.1

Affected products

VendorProductAffected versions
Pac4jPac4j
from 4.0.0 before 4.5.10
from 5.0.0 before 5.7.10
from 6.0.0 before 6.4.1

Weakness classification

References