NetSight
high8.8

CVE-2026-41138

Flowise: Remote code execution vulnerability in AirtableAgent.ts caused by lack of input verification when using `Pandas`.

Impact

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, there is a remote code execution vulnerability in AirtableAgent.ts caused by lack of input verification when using Pandas. The user’s input is directly applied to the question parameter within the prompt template and it is reflected to the Python code without any sanitization. This vulnerability is fixed in 3.1.0.

Affected packages

EcosystemPackageAffectedFixed in
npmflowise<= 3.0.133.1.0
npmflowise-components<= 3.0.133.1.0

Affected products

VendorProductAffected versions
FlowiseaiFlowise
before 3.1.0

Weakness classification

References