high7.0
CVE-2026-41163
bubblewrap is a low-level unprivileged sandboxing tool.
Impact
bubblewrap is a low-level unprivileged sandboxing tool. From version 0.11.0 to before version 0.11.2, if bubblewrap is installed in setuid mode then the user can use ptrace to attach to bubblewrap and control the unprivileged part of the sandbox setup phase. This allows the attacker to arbitrarily use the privileged operations, and in particular the "overlay mount" operation, allowing the creation of overlay mounts which is otherwise not allowed in the setuid version of bubblewrap. This issue has been patched in version 0.11.2.
Affected packages
This record carries no package version data, so it cannot be matched against a dependency list automatically. Read the advisory and compare your version by hand.
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/containers/bubblewrap/releases/tag/v0.11.2
- https://github.com/containers/bubblewrap/security/advisories/GHSA-xq78-7hw4-5jvp
- https://access.redhat.com/security/cve/CVE-2026-41163
- https://bugzilla.redhat.com/show_bug.cgi?id=2468439
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-41163.json