NetSight
critical9.8

CVE-2026-41268

Flowise is a drag & drop user interface to build a customized large language model flow.

Impact

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODE_OPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance. This vulnerability is fixed in 3.1.0.

Affected packages

EcosystemPackageAffectedFixed in
npmflowise<= 3.0.133.1.0
npmflowise-components<= 3.0.133.1.0

Affected products

VendorProductAffected versions
FlowiseaiFlowise
before 3.1.0

Weakness classification

References