NetSight
high8.3

CVE-2026-41271

Flowise is a drag & drop user interface to build a customized large language model flow.

Impact

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, a Server-Side Request Forgery (SSRF) vulnerability exists in FlowiseAI's POST/GET API Chain components that allows unauthenticated attackers to force the server to make arbitrary HTTP requests to internal and external systems. By injecting malicious prompt templates, attackers can bypass the intended API documentation constraints and redirect requests to sensitive internal services, potentially leading to internal network reconnaissance and data exfiltration. This vulnerability is fixed in 3.1.0.

Affected packages

EcosystemPackageAffectedFixed in
npmflowise<= 3.0.133.1.0
npmflowise-components<= 3.0.133.1.0

Affected products

VendorProductAffected versions
FlowiseaiFlowise
before 3.1.0

Weakness classification

References