NetSight
high7.5

CVE-2026-41608

Apache Thrift Python bindings have an Improper Handling of Highly Compressed Data (Data Amplification) vulnerability

Impact

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
pipthrift< 0.24.00.24.0

Affected products

VendorProductAffected versions
ApacheThrift
before 0.24.0

Weakness classification

References