critical9.1
CVE-2026-41677
rust-opennssl has an Out-of-bounds read in PEM password callback when returning an oversized length
Impact
rust-openssl provides OpenSSL bindings for the Rust programming language. From 0.9.0 to before 0.10.78, the *_from_pem_callback APIs did not validate the length returned by the user's callback. A password callback that returns a value larger than the buffer it was given can cause some versions of OpenSSL to over-read this buffer. OpenSSL 3.x is not affected by this. This vulnerability is fixed in 0.10.78.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| rust | openssl | >= 0.9.0, < 0.10.78 | 0.10.78 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Rust-Openssl Project | Rust-Openssl | from 0.9.0 before 0.10.78 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-xmgf-hq76-4vx2
- https://github.com/rust-openssl/rust-openssl/security/advisories/GHSA-xmgf-hq76-4vx2
- https://github.com/rust-openssl/rust-openssl/pull/2605
- https://github.com/rust-openssl/rust-openssl/commit/5af6895c907773699f37f583f409b862284062b1
- https://github.com/rust-openssl/rust-openssl/releases/tag/openssl-v0.10.78
- https://nvd.nist.gov/vuln/detail/CVE-2026-41677