NetSight
critical9.8

CVE-2026-42076

Evolver: Command Injection via `execSync` in `_extractLLM()` function allows Remote Code Execution

Impact

Evolver is a GEP-powered self-evolving engine for AI agents. Prior to version 1.69.3, a command injection vulnerability in the _extractLLM() function allows attackers to execute arbitrary shell commands on the server. The function constructs a curl command using string concatenation and passes it to execSync() without proper sanitization, enabling remote code execution when the corpus parameter contains shell metacharacters. This issue has been patched in version 1.69.3.

Affected packages

EcosystemPackageAffectedFixed in
npm@evomap/evolver< 1.69.31.69.3

Weakness classification

References