critical9.8
CVE-2026-42302
FastGPT is an AI Agent building platform.
Impact
FastGPT is an AI Agent building platform. From version 4.14.10 to before version 4.14.13, the agent-sandbox component of FastGPT is vulnerable to unauthenticated Remote Code Execution (RCE). The startup script entrypoint.sh initializes code-server with the --auth none flag and binds the service to all network interfaces (0.0.0.0:8080). This configuration allows any user with network access to the port to bypass authentication and gain full control over the sandbox environment. This issue has been patched in version 4.14.13.
Affected packages
This record carries no package version data, so it cannot be matched against a dependency list automatically. Read the advisory and compare your version by hand.
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/labring/FastGPT/commit/9d1cafce9241430fb5bcdd646455055c5f4ae0a4
- https://github.com/labring/FastGPT/pull/6781
- https://github.com/labring/FastGPT/releases/tag/v4.14.13
- https://github.com/labring/FastGPT/security/advisories/GHSA-34rc-438g-7w78
- https://github.com/labring/FastGPT/security/advisories/GHSA-34rc-438g-7w78