NetSight
medium6.5

CVE-2026-42357

Apache DolphinScheduler: Incorrect Authorization vulnerability allows users to access workflow instance information belonging to projects they do not have permission to access.

Impact

Incorrect Authorization vulnerability allows users to access workflow instance information belonging to projects they do not have permission to access. This issue affects Apache DolphinScheduler versions prior to 3.4.2. Users are recommended to upgrade to version 3.4.2, which fixes this issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.dolphinscheduler:dolphinscheduler-api< 3.4.23.4.2

Affected products

VendorProductAffected versions
ApacheDolphinscheduler
before 3.4.2

Weakness classification

References