critical9.4
CVE-2026-42569
phpVMS has an /importer authorization bypass causing full database wipe
Impact
phpVMS is a PHP application to run and simulate an airline. Prior to version 7.0.6, a critical vulnerability in phpVMS allowed unauthenticated access to a legacy import feature. This issue has been patched in version 7.0.6.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | nabeel/phpvms | < 7.0.6 | 7.0.6 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-fv26-4939-62fh
- https://github.com/phpvms/phpvms/security/advisories/GHSA-fv26-4939-62fh
- https://github.com/phpvms/phpvms/commit/f59ba8e0e8fc25c60c3faf14e526cfd49df3f7dc
- https://github.com/phpvms/phpvms/releases/tag/7.0.7
- https://nvd.nist.gov/vuln/detail/CVE-2026-42569
- https://github.com/phpvms/phpvms/releases/tag/7.0.6