medium6.1
CVE-2026-42573
Svelte Vulnerable to XSS via DOM Clobbering of Internal Framework State
Impact
Svelte is a performance oriented web framework. Prior to version 5.55.7, Svelte was vulnerable to DOM clobbering of its internal framework state on elements, potentially leading to XSS attacks. This issue has been patched in version 5.55.7.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | svelte | <= 5.55.6 | 5.55.7 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Svelte | Svelte | before 5.55.7 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-rcqx-6q8c-2c42
- https://github.com/sveltejs/svelte/security/advisories/GHSA-rcqx-6q8c-2c42
- https://github.com/sveltejs/svelte/releases/tag/svelte%405.55.7
- https://nvd.nist.gov/vuln/detail/CVE-2026-42573
- https://access.redhat.com/security/cve/CVE-2026-42573
- https://bugzilla.redhat.com/show_bug.cgi?id=2487093
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42573.json