medium6.5
CVE-2026-42580
Netty vulnerable to HTTP Request Smuggling due to incorrect chunk size parsing
Impact
Netty is an asynchronous, event-driven network application framework. Prior to 4.2.13.Final and 4.1.133.Final, Netty's chunk size parser silently overflows int, enabling request smuggling attacks. This vulnerability is fixed in 4.2.13.Final and 4.1.133.Final.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | io.netty:netty-codec-http | >= 4.2.0.Alpha1, <= 4.2.12.Final | 4.2.13.Final |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Netty | Netty | before 4.1.133 from 4.2.0 before 4.2.13 |