high8.9
CVE-2026-42611
Grav is Vulnerable to Stored XSS via Tag Injection
Impact
Grav is a file-based Web platform. Prior to 2.0.0-beta.2, a low-privileged (with the ability to create a page) user can cause XSS with the injection of svg element. The XSS can further be escalated to dump the entire system information available under /admin/config/info whenever a Super Admin visits the page; which can further be chained with the use of admin-nonce to do a complete server compromise (RCE). This vulnerability is fixed in 2.0.0-beta.2.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | getgrav/grav | < 2.0.0-beta.2 | 2.0.0-beta.2 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Getgrav | Grav | through 1.8.0 Version 2.0.0 |