high7.2
CVE-2026-42782
Apache Syncope has an Improper Isolation or Compartmentalization vulnerability
Impact
Improper Isolation or Compartmentalization vulnerability in Apache Syncope. An administrator with adequate entitlements for Implementations can create a malicious Groovy class containing untrusted code reaching a non-sandboxed execution path via the class static initializer. This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0. Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by forcing even the static initializer in Groovy code to run in a sandbox.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.syncope.core:syncope-core-spring | >= 3.0.0-M0, <= 3.0.16 | none recorded |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Syncope | from 3.0.0 through 3.0.16 from 4.0.0 before 4.0.6 Version 4.1.0 |