NetSight
medium4.9

CVE-2026-42797

Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope.

Impact

Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope. An administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access User-related security-sensitive information. This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0. Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by further restricting the JEXL expression definition.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.syncope.core:syncope-core-provisioning-api>= 3.0.0-M0, <= 3.0.16none recorded

Affected products

VendorProductAffected versions
ApacheSyncope
from 3.0.0 through 3.0.16
from 4.0.0 before 4.0.6
Version 4.1.0

Weakness classification

References