NetSight
critical9.8

CVE-2026-43512

DEPRECATED: Authentication Bypass Issues vulnerability in digest authentication in Apache Tomcat.

Impact

DEPRECATED: Authentication Bypass Issues vulnerability in digest authentication in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from before 7.0.0. Older unsupported versions any also be affect Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.tomcat.embed:tomcat-embed-core< 9.0.1189.0.118
mavenorg.apache.tomcat:tomcat< 9.0.1189.0.118
mavenorg.apache.tomcat:tomcat-catalina< 9.0.1189.0.118

Affected products

VendorProductAffected versions
ApacheTomcat
from 7.0.0 through 7.0.109
from 8.5.0 through 8.5.100
from 9.0.0 before 9.0.118
from 10.1.0 before 10.1.55
from 11.0.0 before 11.0.22

Weakness classification

References