high7.5
CVE-2026-43646
Apache Wicket has an Exposure of Sensitive Information to an Unauthorized Actor vulnerability
Impact
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Wicket. This issue affects Apache Wicket: from 8.0.0 through 8.17.0, from 9.0.0 through 9.22.0, from 10.0.0 through 10.8.0. Users are recommended to upgrade to version 10.9.0, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.wicket:wicket-parent | >= 8.0.0-M1, <= 8.17.0 | none recorded |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Wicket | from 8.0.0 through 8.17.0 from 9.0.0 through 9.22.0 from 10.0.0 before 10.9.0 |