NetSight
high7.3

CVE-2026-43869

Apache Thrift has an Improper Validation of Certificate with Host Mismatch Vulnerability

Impact

Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.thrift:libthrift<= 0.22.00.23.0

Affected products

VendorProductAffected versions
ApacheThrift
before 0.23.0

Weakness classification

References