NetSight
critical9.1

CVE-2026-44087

Insufficient Verification of Data Authenticity vulnerability in Apache APISIX.

Impact

Insufficient Verification of Data Authenticity vulnerability in Apache APISIX. The openid-connect plugin under default configuration has an attack surface that allows the attacker to spoof identity headers allowing the attacker to get unauthorized access the protected resources. This issue affects Apache APISIX: from 2.3 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Affected products

VendorProductAffected versions
ApacheApisix
from 2.3 before 3.17.0

Weakness classification

References