NetSight
medium6.5

CVE-2026-44222

vLLM is an inference and serving engine for large language models (LLMs).

Impact

vLLM is an inference and serving engine for large language models (LLMs). From 0.6.1 to before 0.20.0, there is a a Token Injection vulnerability in vLLM’s multimodal processing. Unauthenticated, text-only prompts that spell special tokens are interpreted as control. Image and video placeholder sequences supplied without matching data cause vLLM to index into empty grids during input-position computation, raising an unhandled IndexError and terminating the worker or degrading availability. Multimodal paths that rely on image_grid_thw/video_grid_thw are affected. This vulnerability is fixed in 0.20.0.

Affected packages

EcosystemPackageAffectedFixed in
pipvllm>= 0.6.1, < 0.20.00.20.0

Affected products

VendorProductAffected versions
VllmVllm
from 0.6.1 before 0.20.0

Weakness classification

References