NetSight
high8.1

CVE-2026-44574

Next.js has a Middleware / Proxy bypass through dynamic route parameter injection

Impact

Next.js is a React framework for building full-stack web applications. From 15.4.0 to before 15.5.16 and 16.2.5, applications that rely on middleware to protect dynamic routes can be vulnerable to authorization bypass. In affected deployments, specially crafted query parameters can alter the dynamic route value seen by the page while leaving the visible path unchanged, which can allow protected content to be rendered without passing the expected middleware check. This vulnerability is fixed in 15.5.16 and 16.2.5.

Affected packages

EcosystemPackageAffectedFixed in
npmnext>= 15.4.0, < 15.5.1615.5.16

Affected products

VendorProductAffected versions
VercelNext.Js
from 15.4.0 before 15.5.16
from 16.0.0 before 16.2.5

Weakness classification

References