medium6.1
CVE-2026-44580
Next.js has cross-site scripting in beforeInteractive scripts with untrusted input
Impact
Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | next | >= 13.0.0, < 15.5.16 | 15.5.16 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Vercel | Next.Js | from 13.0.0 before 15.5.16 from 16.0.0 before 16.2.5 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-gx5p-jg67-6x7h
- https://github.com/vercel/next.js/security/advisories/GHSA-gx5p-jg67-6x7h
- https://github.com/vercel/next.js/releases/tag/v15.5.16
- https://github.com/vercel/next.js/releases/tag/v16.2.5
- https://nvd.nist.gov/vuln/detail/CVE-2026-44580