medium4.7
CVE-2026-44581
Next.js vulnerable to cross-site scripting in App Router applications using CSP nonces
Impact
Next.js is a React framework for building full-stack web applications. From 13.4.0 to before 15.5.16 and 16.2.5, App Router applications that rely on CSP nonces can be vulnerable to stored cross-site scripting when deployed behind shared caches. In affected versions, malformed nonce values derived from request headers could be reflected into rendered HTML in an unsafe way, allowing an attacker to poison cached responses and cause script execution for later visitors. This vulnerability is fixed in 15.5.16 and 16.2.5.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | next | >= 13.4.0, < 15.5.16 | 15.5.16 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Vercel | Next.Js | from 13.4.0 before 15.5.16 from 16.0.0 before 16.2.5 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/advisories/GHSA-ffhc-5mcf-pf4q
- https://github.com/vercel/next.js/security/advisories/GHSA-ffhc-5mcf-pf4q
- https://github.com/vercel/next.js/releases/tag/v15.5.16
- https://github.com/vercel/next.js/releases/tag/v16.2.5
- https://nvd.nist.gov/vuln/detail/CVE-2026-44581